Lightbox Not Showing Up? Here’s What To Do.

If your lightbox isn’t showing up as expected, there are a few things you can try to resolve the issue.

1. Make sure you have installed our javascript to the footer of your site. Each site gets its own unique javascript, so if you’re using Digioh on multiple sites, make sure you’re using the right javascript for the right site. To find your javascript, click your name in the upper right-hand corner and then click Setup Instructions from the drop-down menu. On the next page, you’ll several variations on the installation javascript.

2. Make sure you have assigned a condition to the lightbox. Your lightbox will be unable to fire if it doesn’t know when and where it should show up. There are two ways to add a condition. You can do so from the list of lightboxes in your account:

Or from within the lightbox editor:

3. Make sure your lightbox is turned on, and published. You’ll see a on/off button tot he far right of the list of lightboxes. Be sure it’s set to “On”. If there isn’t a green checkmark to the right of that button, be sure to publish the lightbox as well.

4. Make sure you’re using the right javascript code for your site. We have unique javascript for Wordppress, and Google Tag Manager.

5. If you’re using Google Tag Manager, be sure to set your lightboxes to fire on both the HTTP and HTTPS version of the page.

STILL NEED HELP! I did all the above and lightboxes have been showing up before, but they still aren’t showing up. Okay! Try these out:

  • Try testing in an incognito window (if you have session based rules or are using master rules), this might work.
  • Make sure you don’t have conflicting rule. (email us and we can help you figure this out)

If you tried these steps, or if you’d just like our help, email us, we’ll help you get up and running in no time!